Power Outage

Major incident O'Briens Bridge Monaleen Ballysheedy
2021-03-30 07:30 UTC · 1 month, 1 week, 5 days, 16 hours, 10 minutes, 45 seconds

Updates

Investigating

We’ve identified the issue and are working on resolving it as quickly as possible.

  • MBB Team
March 31, 2021 · 23:11 UTC
Investigating

We’re currently experiencing problems at two of our highsites at O’Briens Bridge and are investigating the issue.

  • MBB Team
March 30, 2021 · 07:58 UTC

← Back